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General Improvements
DaVinci Resolve 19.1 has a variety of general improvements across the application, 
as well as new DCTL and Scripting functionality.

Dual Screen Layouts allow 
Secondary Screen Resizable Window
The secondary screen in a Dual Screen layout is now resizable.

Help Menu Search for Menu 
Actions in Windows and Linux
Windows and Linux users can now search for specific Application Menu items 
(File, Edit, Trim, Timeline, etc.) by using the search bar in the Help menu.

Application Menu Actions to 
go to Previous or next Timeline
You can now step through timelines forwards or backwards using the 
menu options in Playback > Previous / Next > timeline.

Marker Notes Metadata 
Tags in Data Burn-In
You can use marker notes for display in Data Burn-Ins. To do so:

1	 Create a Marker and add a word or words in the Notes section.

2	 Open Workspace > Data Burn-In.

3	 Check one of the Custom Text options.

4	 In the field that opens type the “%” sign, and then start to spell the word “marker”.

5	 Choose Marker Notes from the list.

6	 Adjust the font/position/opacity parameters as necessary.
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Any text that you put in the Marker Notes section will now show up as a Data Burn-In. If you 
want the notes to last more than a single frame, make sure to change the marker to a duration 
marker instead.

The marker note “Stock Footage” is now a Burn-In, using the % metadata tags in a Custom Text field
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DCTL
Detailed documentation for the DaVinci Color Transform Language (DCTL) can be found in Help 
> Documentation > Developer. Below are the changes to DCTL in DaVinci Resolve 19.1.

New random generator function RAND(uint p_Seed): The new RAND(uint p_Seed) 
function generates random values with a uniform distribution. Users can also utilize 
TIMELINE_FRAME_INDEX or other variables as a seed to create temporally deterministic 
effects across systems. Refer to chapter III - section 3 (line 129) in README.txt.

Alpha channel support for Transform DCTL in DCTL plugin: Transform DCTL can now 
manipulate alpha channel of input RGBA image through the ResolveFX DCTL plugin. Users 
can define the alpha modes for both input and output images in the DCTL effect with alpha 
tag keywords. Refer to chapter III - section 7 (line 260) in README.txt

Custom UI Color Picker: Introduce new UI element color picker for users to pick color from 
the viewer and pass it as a control parameter for DCTL. Refer to chapter III - section 7 (line 
226) in README.txt.

Custom tooltips when users mouse over labels: When hovering on a UI control's label, a 
custom tooltip text can be defined inside the DCTL. Refer to chapter III - section 7 (line 250) 
in README.txt.

View the expiry date for encrypted DCTLs in the LUT browser list: The new Expired Date 
column in the LUT browser list allows an easy ay to review expiry dates for encrypted DCTLs.

DCTL build error dialog when using the DCTL plugin: When loading a faulty DCTL in the 
DCTL effect, build error messages are shown in a popup dialog. Users can view the dialog 
again by triggering Reset button. Refer to chapter III - section 7 (line 217) in README.txt.

Scripting API
Detailed documentation for the scripting support can be found in Help > Documentation > 
Developer. Below are the additions to scripting functions in DaVinci Resolve 19.1.

	� Load cloud projects.
	� Query and set mark in and out ranges.
	� Auto sync media pool clips using audio waveform or timecode.
	� Render options for start frame, start timecode and to replace files.
	� Ability to delete a render preset.
	� Invoke Quick Export renders.
	� Reset all grades and nodes from node graph.
	� Apply grade from DRX and CDL LUT to layers from the Graph API.
	� Create gallery albums.
	� Query and set per-node cache modes.
	� Query and enable clip cache for Fusion output and color output.
	� Query media pool entry for a timeline.
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Media
DaVinci Resolve 19.1 includes a new Resync function and some small, but helpful, 
changes to the Media Pool functions.

Sync Media Pool Bins 
with File System Folders
You can now sync a Media Pool bin with a folder on your computer’s file system (MacOS, 
Windows, Linux, etc.). This allows you to add additional media into a folder on your computer and 
have it automatically import to its respective bin in DaVinci Resolve.

To set up a folder with Automatic Syncing:
1	 On the Cut page, use the Import Folder icon on the top menu bar to set up matching folder 

and sub folder names.

Use the Import Media Folder icon in the Cut page

2	 Right-click on the imported folder and choose “Automatically Resync Media Files.” 

 

Right-click on the bin and select Automatically Resync Media Files
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Newly added clips in this folder will be added automatically to the media bin. This can be 
useful when working with cloud-synced media files (as when using DaVinci Resolve’s Replay 
capabilities), or any files that may be added to the folder later.

To manually resync the contents of a Media Pool bin once, right-click a bin and choose 
"Resync Media Files.”

 

Right-click on the bin and select Resync Media Files  
to perform the sync operation manually

For both Resync actions, ensure that: 
	� At least one clip is present in the media bin.
	� 	All existing clips in the media bin share the same file path.
	� The media bin name matches the parent folder of the clip paths. You can 

ensure this is set up correctly by using “Import Media Folder” in the Cut page, or 
“Add Folder and SubFolders into Media Pool (Create Bins)” in the Media page.

Sync actions will add new clips from sub-folders if the corresponding sub-bins exist. However, 
newly created sub-folders without corresponding media bins are not tracked, and new 
media bins without the corresponding sub-folders are skipped. As of 19.1, image sequences 
are not supported.

For example, say you were editing a sporting event and you had a graphics operator creating 
animated lower-thirds for each of the players. By creating a common network folder called “CG” 
and automatically syncing it in DaVinci Resolve, each time a new lower-third was finished and 
saved it would automatically appear in your bin in the Media Pool ready for use.

Here’s how you would set this up: 
	� Create a folder on your network storage called “CG.” Both the editor and the graphics 

operator need to have access to this folder.
	� Note that because this folder is currently empty, it can not be used in a Resync action 

yet. Only after there is at least one media file in the folder can you perform a Resync.
	� The graphics operator finishes his first animated lower third and saves it to the “CG” 

folder as a .mov file (though any DaVinci Resolve readable media format would work, 
except for image sequences).

	� The editor then imports the “CG” folder into the Media Pool in DaVinci Resolve, and 
selects Automatically Resync Media Files from the context menu.

	� As the graphics operator finishes and saves additional lower thirds into that folder, 
they automatically appear in the Editor’s “CG” bin in the Media Pool, without having to 
specifically import them.
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	� For organizational purposes, the graphics operator then creates a new folder in 
“CG” for the other team, called “Team B.” Unfortunately, because this folder structure 
was not in the original imported bin, it does not show up in the editor’s Media Pool. 
However, if they had created this Team B folder before the editor imported it, and it 
had media in it, it would been there.

	� Now in this case, the editor simply imports the same bin again, selects Automatically 
Resync Media Files, and the new folder and all its media appear as expected. 
Any further files in dropped in “Team B” will show up in the editor’s Media Pool.

IMPORTANT: Media entries for clips that are removed or not found on the file 
system are set as offline media. This allows for retention of metadata and is useful 
when the clip path is temporarily offline, on cloud storage where file status may be in 
flux, or moved away by apps or workflows seeking to write a new version in its place.

Export Multiple Timelines 
from the Media Pool
You can export multiple timelines from the Media Pool as separate DaVinci Resolve Timeline 
(.drt) files. Simply select all the timelines you want to export in the Media Pool, right-click on any 
of them, and select Timelines > Export > DaVinci Resolve Timeline Files. Then select the folder 
where you wish to save them from your file browser.

Unlike exporting individual timelines, when exporting multiple timelines you will not be able to 
rename the .drt files on export. They will retain the timeline name they have in the media pool.

Media Pool Remembers Last 
Opened Bins and Column Sort Order
As a simple quality of life improvement, DaVinci Resolve’s Media Pool will now remember the last 
opened bins, and any column sort orders you set over a restart. This saves you a bit of time and 
mental energy each time you open the project.

Smart Bin and Smart Filter Option 
to Filter Media from a Specific Bin
When creating a Smart Bin (in the Edit Page) or Smart Filter (in the Color Page), you can now 
filter media in a specific bin as one of the criteria. To do so, create a rule in the Create Smart 
Bin dialog box using Media Properties > Clips in Bin > is/is not/contains > (Bin Name). A list of all 
current bins are available in the option (3 dot) menu next to the bin name field.
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Retain Video Metadata and Embedded 
Audio when Syncing Audio Manually
When syncing audio to video manually in the Media Page, you can now choose whether to 
include the original camera audio tracks in the synced file, or whether to retain the camera 
scene/take metadata, rather than have the audio file scene take metadata overwrite it as normal.

In the Media Page > Audio > Waveform Tab, the option (3 dot) menu now offers 2 choices:

The Audio > Waveform Tab (3 dot) option menu lets you  
choose to retain embedded audio and/or video metadata.

Retain embedded audio
When enabled, embedded camera audio tracks are included with any newly synced audio 
during the manual linking process (using the link icon on this pane).

Retain video metadata
Default is off, which means that video files that are synced to audio files inherit metadata 
(e.g., scene and take) from the audio file. When this option is checked, the video file’s 
metadata is retained and not overwritten instead.

Media Management Audio 
Transcodes Default to 24 bit
When using the Transcode settings in the Media Management tool, the default audio bit rate is 
now 24 bits. This can be manually changed either to 16 or 96 bits in the Audio Bit Depth selector 
in the Transcode > Audio tab in the Media Management interface.
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Relink Media Pool Clips from all Pages
You can now perform the Relink Clips function from all pages (except Deliver) across the 
DaVinci Resolve application, by clicking on the Relink icon in the Media Pool header on 
each page.

Templates Using .drb Files 
can Include Empty Bins
If you want to export a DaVinci Resolve Bin (.drb) file to use as a template, 
they can now include empty bins.

Change Start Timecode for 
Multicam and Compound Clips
You can change the starting timecode for both Multicam and Compound clips. To do so, 
right‑click on the Multicam or Compound clip in the Media Pool, and select Starting Timecode 
from the context menu. A Set New Start Timecode box will appear, then type in the new starting 
timecode you wish to use and click OK.
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Edit
The Edit Page in DaVinci Resolve 19.1 has been updated  
with several quality of life improvements.

Searching For Effects and 
Transitions Using Category Names
You can search for effects and transitions using Category Names as a search term. 
For example, searching for “Stylize” will bring up all the Resolve FX under the Stylize section.

Marker Index Search 
Includes all Marker Fields
When searching for Markers in the Markers Index, the search returns results from all fields in the 
Markers window. This includes Name, Notes, and Keywords fields.

Set the Location of  
the Fixed Playhead
When using the Fixed Playhead option in the Edit Page, you can now choose where to set the 
location of the Fixed Playhead in the timeline, rather than just have it in the center. To do so, 
hover the pointer over the top of the playhead in the Timeline Ruler and drag it to the new 
location you want to use. 

Moving the Fixed Playhead can be useful in increasing the amount of timeline working area for 
clips before or after the current position.

Clips are Always 
Pasted at Playhead Position
In a slight change to the editing tools, when you perform a paste operation in the timeline, 
the clip will now always be pasted at the playhead position, regardless of any in and 
out points set on the timeline.

Delete Multiple Selected 
Tracks via the Track Index
You can now select multiple tracks in the track index allowing you to delete all 
selected tracks with one operation.
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Timeline Aspect Ratio Option 
in the Safe Area Overlay
There is a new Default choice in the safe area overlays that allows you to 
preview the timeline aspect ratio.

Applied Fusion Templates 
Automatically Cached
Fusion effect templates applied to clips on the timeline now have more granular caching as well 
as automatic render caching options. 

The Render Cache Fusion Effect Filter menu in the timeline clip context menu has a new 
Auto option that is enabled by default. When render cache is set to smart, any Fusion effects 
and templates applied to a clip are automatically cached. Disabling auto allows you to 
individually pick which effects to cache. 

When render cache is set to user, the Auto option automatically caches the Fusion effects 
if the project setting to Automatically cache Fusion Effects in user mode is enabled. 
If the project setting is disabled, Auto mode does not cache any Fusion effects unless you 
individually select them.

Access to the Track Equalizer, Dynamics 
and Plugins from the Audio Mixer

Double-Click on one of the circled  
Track Effects to open those controls in the Edit Page

You can immediately access audio 
track effects from the Audio Mixer in 
the Edit page. 

Double-click on one of the track 
effects at the top of the fader controls, 
to open them.

FX: Opens the Track Effects  
controls in the Inspector 
EQ: Opens the Track Equalizer
DY: Opens the Track Dynamics
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Audio Ducker Supports Multiple 
tracks to Trigger Ducking
You can now choose from multiple audio tracks as sources to trigger audio ducking. 
This allows you to use the audio ducker across say a music and an FX track at the same time.

To open the Ducker directly on the Edit page:

1	 Open the Inspector, and Audio Mixer

2	 Access the Ducker by double clicking the “FX” widget label in the audio mixer (above the 
fader). This will open the inspector pane to show Track FX, including the Ducker.

Pressing the +/- icons on the Ducker lets you add and remove tracks to the analysis. 
Clicking on the GUI icon in the upper right, opens the graphical user interface for the ducker.

By choosing Ducker as a track effect, you can access this capability in either 
the Floating GUI or Inspector controls.

In the Inspector, you can add multiple sources (or delete them) for the 
Ducker analysis by using the + and - icons to the right of the source dropdown.

Command-clicking tracks in the Source dropdown menu,  
lets you add or remove tracks in the Ducker GUI

You can access the Ducker GUI by clicking on the GUI tool icon in the upper right of 
the Inspector if on Edit page, or mixer Track FX insert in the Fairlight page. You can add 
multiple sources in the GUI by Command-clicking in the source dropdown menu.

NOTE: The ducker may not appear in the Inspector on older projects 
created prior to v19.
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Toggle Track Header Control States 
by Clicking and Dragging

You can change multiple Track Header 
controls in the Edit page (Lock track, 
Visibility, Auto Track Selection, etc.) 
by simply clicking on an icon and 
dragging your pointer up or down across 
the track headers. You can do this for one 
type of control at a time and not across 
Audio and Video tracks.

Clicking on the Lock icon on A1 
then dragging the pointer down to A3, 
will lock all audio tracks in between.

Individual Destination Controls 
with Decompose on Edit from 
Compound Clip/Timeline Sources.

In Edit > Edit Options, when the setting to 
Decompose Compound Clips on Edit is 
enabled, compound clips and timelines 
either selected in the Media Pool or loaded 
in the Source Viewer have support for track 
destination controls from the underlying clip. 

This means that if a timeline with three 
video tracks and two audio tracks is loaded 
into the Source Viewer, the Timeline 
Track destination controls will show three 
available video tracks and two available 
audio tracks for track destination patching. 

With Edit > Edit Options > Decompose Compound 
Clips on Edit enabled, the resulting matching 
timeline headers when decomposing a timeline 
with three video tracks and two audio tracks

14DaVinci Resolve 19.1 Edit



Apply Track Destination Controls 
Using a Track Header Context Menu

In addition to dragging the track destination 
controls between tracks in the timeline track 
headers, you can now right-click in a track 
destination to access a context menu to 
quickly choose and assign a source audio 
or video track.

This is especially useful for source clips 
with multiple audio tracks or timelines with 
multiple video tracks to quickly assign 
track destination controls. Additionally, 
when your source has more tracks than 
available on the timeline, the context menu 
gives you access to patch the additional 
tracks in the source.

Right-clicking on the destination 
control (A1) opens a contextual menu, 
letting you quickly choose which 
audio track of your source clip will be 
edited to track A1 on the timeline.

Edit Menu Setting to Optionally 
Not Create New Tracks when 
Adding Clips to a Timeline
There is a new menu item in Edit > Edit Options called Automatically Create Tracks on Edit. This 
option is on by default, and preserves DaVinci Resolve’s default behavior of automatically adding 
new tracks to the timeline if your source material has more audio tracks than your timeline does.  

When disabled, you now have the ability to drag source clips on to the timeline without the 
timeline automatically creating new tracks for the additional audio or video elements. In situations 
where your source camera files have more audio tracks than on your timeline, disabling this 
option will not create additional new tracks and will only bring elements visible in the track 
destination controls. 

This can be useful if for example, you wanted to only bring a single mixed track in with a clip from 
a multitrack recorder and exclude the independent microphone tracks.
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Use Native Audio Channels from Source 
when Editing Multicam Angles
In previous versions of DaVinci Resolve, all the audio tracks and channels for an angle are 
placed in a single adaptive track wide enough to cover all the audio channels in the source. 
The multicam clip audio is then placed on a timeline on an adaptive track.

Starting with DaVinci Resolve 19.1, there is a new option in the multicam creation dialog to Use 
source audio channels. This option is enabled by default. With this new option enabled, the 
multicam is created in a mode where you have access to the individual tracks and channels in 
the source angle.

Once the multicam clip is created 
with this option enabled, you can 
preview the audio tracks in the 
Audio Configuration section in the 
inspector File tab. With the option 
disabled, the multicam clip audio 
will be placed in an adaptive track. 
With the option enabled, the audio 
will be placed in the track format 
of the source.

Multicam audio clips also have the 
ability to select alternative mono 
audio channels from the timeline 
clip context menu (including 
Command right-click for faster 
access) and from the timeline 
clip audio configuration section 
in the inspector.

Using native audio channels  
lets you access individual tracks  
in the source angle

Select Timeline Mono Audio 
Channels from the Clip 
Context Menu or from Inspector
You can now change your mic (or other) audio sources on mono channel lanes in the Edit page 
by using a context menu or via the inspector. This can be handy when editing using a mix track 
and you find there is a lav mic that has noise on it and you want to use boom audio instead.

There are two methods for changing mono audio sources, in the timeline or in the inspector.
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Changing mono audio sources via context menu on the timeline:

If you are on a mono timeline track and the parent audio file for your track contains 
multiple mono tracks, right-click on it and an Audio Channel choice appears at the bottom 
of the context menu. You can then choose any mono source from the hierarchical menu.

Right-Clicking on an audio clip will reveal the  
source audio channel choices to choose from

Command right-click on an audio clip in the  
timeline to reveal just the source audio channels

Alternatively for an even more 
streamlined workflow, you can press 
Command right-click and you will 
then get a dropdown only with the 
mono sources.

Changing mono audio sources via the Inspector:

You can change the audio channel by using 
a dropdown menu on the channel in the File 
Inspector in the Audio Configuration section.

When a timeline clip is opened via the 
File Inspector, you can change mono 
track/lane sources by using a dropdown 
on the channel waveform.
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Set Individual Audio Channels 
to None in Clip Attributes
In the Audio tab of the Clip Attributes window, you can now select “none” as an 
option for an audio Source Channel. This allows you to remove specific channels from 
the multichannel audio file. 

Nested Timeline and Compound 
Clip Support for Match Frame 
and Match Frame to Source
Previously the Match Frame to Source Clip feature was only supported for multicam clips on the 
timeline. This feature has now been enhanced to work on compound clips as well as nested 
timelines. Additionally, you can now invoke the function from either the timeline (and timeline 
viewer) or the source viewer. Based on the context, the relevant underlying source clip is loaded 
into the source viewer.

With a compound clip or timeline loaded in the source viewer, when performing a match frame 
(from the source viewer) Resolve prioritizes finding a nested copy of the clip in the timeline to 
perform the match frame. If a nested copy is not found, match frame is automatically performed 
to match the underlying source clip to a timeline instance. 

Similarly, when the match frame is performed from the timeline (or timeline viewer), Resolve first 
attempts to find the same underlying clip and frame in the compound clip or nested timeline 
loaded in the source viewer. If the frame cannot be found then match frame to source is 
automatically performed as usual. This is especially useful when you are comparing 2 different 
versions of a timeline and going back and forth. 

Audio Inspector can Adjust Trim Levels 
of Individual Channels in a Source File
The level of individual source clip channels in the audio inspector can be be adjusted via a trim 
control. This allows source clip audio in one channel or to be brought up in level, or brought 
down in level as needed. 

The trimmed level is internal to source clip in the media pool and will be inherited whenever that 
source clip configuration is used on a timeline unless it is changed.

NOTE: The trim level is totally separate from clip gain in the timeline. Be aware that 
trimmed levels can clip if you move them too high.
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You can adjust the trim levels of individual 
audio channels in a multichannel clip.

Using the Trim slider
1	 Select one or more channels in the Audio Configuration section of the File Inspector

2	 Adjust the Level slider at the bottom to the desired audio level.

The waveform will adjust dynamically to the level value, and will display a trimmed value 
in dB in the channel itself. If you have multiple lanes selected, all channels will be trimmed 
together. Relative levels are not stored, so if you adjust one, it will then force any others in 
the selection to match. When no channel lanes are selected, the Level control is grayed out.
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Fusion
The Fusion Page has received new tools, and expanded USD capability in DaVinci Resolve 19.1..

Field Dominance Changes are 
Honored in Interlaced Media Inputs
When using interlaced media, changes in field dominance now are respected by Media Inputs.

Polygon and B-Spline Viewer 
Toolbar Controls for MultiPoly Tool
When using the MultiPoly node, a Viewer toolbar provides several controls for manipulating 
shapes. This toolbar includes two new controls: “Add Polygon” and “Add BSpline.” 
Pressing either of these buttons adds a Polygon or BSpline to the tool’s list, allowing you 
to begin drawing a new shape in the Viewer.

The Add Polygon and Add BSpline controls  
in the Viewer using the MultiPoly tool

OCIO CDL Transforms Can 
Be Used as View LUTs
You can use an OpenColorIO (OCIO) CDL Transform as a View LUT in the Viewer. To do so, 
simply click on arrow next to the LUT icon in the upper part of a Viewer, and select OCIO CDL 
Transform from the list.
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Support for USD 24.08 with Improved 
MaterialX Performance
DaVinci Resolve 19 and Fusion Studio 19 now support the Universal Scene Description (USD) 
format version 24.08 and increased MaterialX performance.

Freeze Frame with TimeSpeed
The TimeSpeed tool has a new Freeze Frame button, which when pushed, automatically adjusts 
the Speed and Delay controls to freeze playback on the currently selected frame.

The new Freeze Frame button in the TimeSpeed tool

OCIO Display [OCD]

The OCIO Display node

OCD Display Node Introduction
The OCIO Display node allows you to apply an OpenColorIO (OCIO) 
Display transform (.ocio) to an input.

Inputs
The single input on the OCD Display node is used to connect the node you want to apply 
the OCIO Display transform to, and an effect mask, which can be used to limit the display 
transform area.
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Basic Node Setup
Connect the media or tool that you wish to apply the OCIO Display transform to the input. 
The output of the node then gets passed to the remainder of the node tree.

 

A simple node tree showing the OCIO Display node taking a the Media In node, 
performing the Display Transform, and passing it to Media Out.

Inspector

Controls
The OCIO Display controls lets you load and apply an .ocio configuration file, and apply its 
color space and display transform to to the node’s input.

The OCIO Display controls

OCIO Config File: Click the Browse button to open up a file system 
prompt to locate the .ocio file.

Source Space: Choose the color space of the source material from the list.

Display: Choose which monitor your viewer is on.

View: Choose which color space to view.
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Switch [Swi]

 

The Switch node

Switch Node Introduction
Switch is a tool that enables artists to alternate between multiple input sources, allowing the 
selection of one output from the chosen inputs. This capability is especially useful for toggling 
between different visual elements within a composition. The number of input connections can 
vary, with the node supporting a dynamic number of inputs that can be renamed as needed. 
Controls in the Config tab allow users to add or remove inputs and change their names.

Switch works with most types of tools, including Shapes and 3D. Additionally, users can find the 
Switch modifier in the Modify With and Insert submenus of a control’s context menu, allowing it to 
be applied to any supported control.

Inputs
You can add up to nine inputs to a Switch node using the slider in the Config tools. If you need 
more than nine sources, you can type that number manually into the Number of Inputs field.

Basic Node Setup
Connect as many input sources as you wish to the Switch node, and connect its output to the 
rest of the node tree.

The Switch tool receiving three media inputs, allowing  
you to choose one to go through the Transform node.
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Inspector

Controls
The Switch controls consist of a Source switcher that lets you 
choose which source to pass through the switch.

The Switch controls let you choose  
a source to pass through the switch.

Config
The Switch configuration lets you choose the number of inputs and rename them.

The Switch Configuration

Number of Inputs: Adjust the slider to add the number of inputs you wish to use 
up to nine. If you want more than nine inputs, you can click in the number field 
and type the number manually.

Name X: You can change the name of the input from numerical to something 
more descriptive.
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uExport [uEx]

The uExport node

uExport Node Introduction
The uExport node is designed to export scenes in the Universal Scene Description (USD) format. 
The node allows users to export their USD scene, including geometry, materials, animations, and 
lighting, into a USD file. This upgrade marks an important advancement in Fusion’s functionality, 
enabling users to seamlessly share complex USD assets and facilitating smoother workflows in 
collaborative environments.

The node offers controls to choose between different USD formats such as usd, .usda, .usdc, and 
.usdz. It is also possible to export specific nodes in the source tree as a hierarchy of linked USD files.

Inputs
There is one input on the Background node for a USD scene input.

Inspector

Export
The Export controls let you set the format of the exported USD scene.

 

The uExport control

Export Stage: Press this button to open a file browser to select where 
to store your USD scene.

Format: Choose a format for your USD scene.
	� USD (*.usd)
	� USD UTF-8 (*.usda)
	� USD binary (*.usdc)
	� 	USD packaged (*.usdz)
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uSwitch [uSw]

 

The uSwitch node

uSwitch Node Introduction
uSwitch functions similarly to Switch but is specifically designed for the USD environment.

uSwitch is a tool that enables artists to alternate between multiple USD input sources, 
allowing the selection of one output from the chosen inputs. This capability is especially 
useful for toggling between different visual elements within a composition. The number of 
input connections can vary, with the node supporting a dynamic number of inputs that can be 
renamed as needed. Controls in the Config tab allow users to add or remove inputs and change 
their names.

Inputs
You can add up to nine inputs to a uSwitch node using the slider in the Config tools. If you need 
more than nine sources, you can type that number manually into the Number of Inputs field.

Basic Node Setup
Connect as many input sources as you wish to the uSwitch node, and connect its output to the 
rest of the node tree.

The uSwitch tool receiving five USD media inputs,  
allowing you to choose one to go out to uRender.
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Inspector

Controls
The Switch controls consist of a Source switcher that lets you choose which source to pass 
through the switch.

The uSwitch controls let you choose  
a source to pass through the switch.

Config
The uSwitch configuration lets you choose the number of inputs and rename them.

The uSwitch configuration

Number of Inputs: Adjust the slider to add the number of inputs you wish to use up to 
nine. If you want more than nine inputs, you can click in the number field and type the 
number manually.

Name X: You can change the name of the input from numerical to 
something more descriptive.
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Color
The Color page has seen several quality of life improvements in DaVinci Resolve 19.1. 

Dedicated Custom Curve Controls 
on DaVinci Resolve Mini Panel
Similar to the DaVinci Resolve Advanced Panel, you now have more control over selection and 
manipulation of custom curve points using the DaVinci Resolve Mini Panel. When in Custom 
Curves mode, you will see two new controls for the lower-right knobs labeled Select CTRL Point 
and CTRL Point LEFT/RIGHT. 

The first knob allows switching between the different control points in order to select similar to 
the fourth ring on the DaVinci Resolve Advanced Panel. The second knob allows you to move 
the selected control point left or right in the Custom Curves Graph.

Copy Active Node Stack Layer 
from Timeline Clips
You can copy (not just apply) the Active Node Stack layer from a Timeline Clip in the Gallery. 
To do so, right-click on a Timeline Clip in the Gallery and select Copy Active Layer. 

Set the Default Qualifier 
Mode for New Clips
You can now set your favorite qualifier to open as the default when you apply a qualifier on a 
new clip on the timeline. This can save a significant amount of clicks over the course of a project. 
As expected, if a qualifier other than the default has been applied to the clip, that qualifier will 
open instead.

To change the Default Qualifier, click on the Qualifiers (3 dot) option menu, 
select Default Qualifier, and choose an option from the list.

Changing the Default Qualifier to 3D, which will now open 
the 3D qualifier instead of the HSL qualifier on new clips.
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Post Group Node Stack Layer
In Project Settings under General Options > Color, there is a new checkbox called Post Group 
Node Stack Layer. When you enable this checkbox, the last node stack layer is processed after 
the Group Post-Clip node graph. This function allows you to dedicate the last node stack layer 
for post group grades and transforms. 

Checking the Post Group Node Stack Layer box in Project Settings > Color

The revised node stack order now processes 
Layer 3 Special Sauce after the Group Post-Clip layer 
(that is automatically generated when you group clips). 
Normally the Group Post-Clip layer would be last.

Track Node Changes 
and Filter Using Color
The Color Page Node Graph 3-dot option menu has a new option to Track Node Changes 
Using Color. This is a per system setting where you choose the node color you want to apply to 
newly created or modified nodes. 

In a multi-user collaboration environment, each colorist can set their own preassigned node 
color. Then, based on the node color, you can easily know who last modified a specific node. 
In single user scenarios, this feature can be used to track changed nodes and grades after a 
particular point in time, such as a client review session. 
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Selecting Track Node Changes Using Color from the Node Graph option menu will subsequently 
change the color bar on a node after any modification made to that node. In this case, 
the Highlights node’s color bar is now Violet after the Violet user has made a change to it.

Additionally, you can filter timeline clips by their node colors as well. To do this simply 
click the Down Arrow in the Clips tab, hover over Node Color, and select the color you 
wish to filter by clicking on it. You can repeat this process to filter multiple colors.

When set, only the clips that have the selected node colors will appear in the timeline.
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Persistent Object Mask Caches
Object Mask Caches are now persistent until manually cleared or re-analyzed, making it much 
faster to iterate with your object masks.

Channel Name Tooltips for 
Splitter/Combiner and Matte Nodes
Channel Names will now appear as tool tips if you hover the pointer over the inputs and outputs 
of Splitter, Combiner, and Matte nodes. This makes it easier to keep track of what each color 
channel is and where it’s going.

Hovering the pointer over a Splitter Node’s output will tell you the color channel of that output.

31DaVinci Resolve 19.1 Color



Resolve FX
DaVinci Resolve 19.1 adds control improvements to Sky Replacement, Light Rays, and Blur effects. 

Show Legacy Resolve FX
Over time some Resolve FX are depreciated for various reasons, such as their functionality being 
absorbed into another effect or being re-written completely. However, for working on projects 
that may have used these older effects extensively, or if you’re just feeling nostalgic, you still 
have access to them.

To show the Legacy Resolve FX
Open the Effects tab, and click on the Effects (3 dot) option menu. Then select Show Legacy 
Resolve FX. You can remove these effects from the list again by unchecking this setting.

Grain Controls for Resolve FX 
Sky Replacement
Grain Controls have been added to the Resolve FX Sky Replacement effect. These controls are a 
simplified set of tools to emulate the grain patterns found on motion picture film. This control will 
help you blend in the replacement sky more seamlessly with the original footage.

The Grain controls in the Sky Replacement effect
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Sky Integration
These controls help you match the attributes of the final sky to the foreground footage.

Preview Final Sky: Check this box to view only the final sky output, including 
motion and any keyframed parameters.

Lens Distortion: Adjust this to warp the sky to match the curvature of 
the original camera lens.

Lens Defocus: Adjust this to move the sky out of focus and match the depth of 
field of the original lens.

Exposure: Lets you adjust the overall brightness of the sky.

Add Grain: Check this box to turn the grain pattern on or off.

Grain: Determines the amount of grain to add in the sky.

Size: Determines the size of the grain in the sky.

Softness: Determines how crisp the individual grains are.

Saturation: Adds color to the grain. 0 is monochromatic.

Saturation and Gamma Controls 
for Resolve FX Light Rays
Gamma and Saturation Controls have been added to the Resolve FX Light Rays effect. 

The Gamma and Saturation controls in the Light Ray effect
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Appearance
Appearance parameters let you customize the ray effect. 

Ray Dropoff: A pop-up with four options.
	� Default (soft): Produces soft, indistinct rays of light that appear to fade away as they 

stream out.
	� Keep Shape of Source: The edge of the light rays are defined by the shape that 

emitted them.
	� CCD Bloom Harsh: Severely raises the brightness of the part of the image that’s 

emitting rays as Length is raised, resulting in harsh glow or bloom in the image.
	� CCD Bloom Soft: Gently raises the brightness of the part of the image that’s emitting 

rays as Length is raised, resulting in a very gentle lightning of the image.

Length: Lets you make the rays longer or shorter.

Soften: Lets you blur the rays being emitted.

Brightness: Lets you adjust how bright the rays are.

Gamma: Adjusts the brightness of the ray effect using a gamma curve.

Saturation: Adjusts the intensity of the ray’s color.

Color: A color picker and eyedropper let you define a color with which to tint the rays.

Composite Type: Lets you choose a composite mode to use to blend the glow effect with 
the image. Defaults to Add, which is good for hotter, more intense rays. Screen lets you 
create more gentle rays, while other composite modes let you create other varied effects.

Bright Region Recovery: Adjust this slider to reclaim some image detail in areas that are 
blown out by the rays.
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Halation Saturation Control 
for Resolve FX Film Look Creator
A Halation Saturation control has been added the the Film Look Creator effect. 
This lets you adjust the color intensity of the halation affected areas.

The Saturation controls in the Film Look Creator effect

Halation
These controls are a simplified way of adding soft glows to the edges of the subjects in your 
frame to mimic this characteristic of motion picture film. If you want more control, you can disable 
this setting and use the Halation effect instead.

Length: Lets you make the rays longer or shorter.

Enable Halation: Turns the Halation effect on or off.

Highlights Only: Limits the Halation effect only to the edges of highlights.

Amount: Lets you set the intensity of the halation.

Radius: Lets you set the spread size of the glow from the edges.

Saturation: Lets you adjust the color intensity of the halation.

Hue: Lets you tint the glow a selected color.
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Per-Channel Settings for Blur Effects
A Channel Adjustment section has been added to most Resolve Blur FX, allowing you to now set 
the strength of a blur in a specific channel, relative to the strength of the overall blur. 

The Channel Adjustment controls in various Blur FX

Channel Adjustment

Red: Adjusts the blur of the Red Channel relative to the overall blur.

Green: Adjusts the blur of the Green Channel relative to the overall blur. 

Blue: Adjusts the blur of the Blue Channel relative to the overall blur. 

Alpha: Adjusts the blur of the Alpha Channel relative to the overall blur. 
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Fairlight
DaVinci Resolve 19 offers the following new features and enhancements for Fairlight.

Fairlight FX Improvements

Track FX on Stereo Linked Groups
Track effects can now be applied to stereo-linked groups (stereo-linked tracks).

Ducker – Multiple Audio Tracks as Input Sources
The Ducker now supports using multiple audio tracks as input sources, which, for example, 
is useful when mixing a scene where three characters are having a conversation next to a 
noisy freeway.

In this instance, with only one input source (Dialogue 1), the Ducker would only be effective when 
the first character speaks. This new feature lets you use the audio tracks for other characters 
(Dialogue 2 and Dialogue 3) as input sources for attenuating the traffic noise.

With Dialogue 1 already being used as an input source, you can add Dialogue 2 and Dialogue 3 
in either the Ducker interface or the Inspector.

To add multiple tracks as input sources via the Ducker interface, click the Source drop-down, 
then Command-click the additional track names; in this example, Dialogue2 and Dialogue3. 

Adding multiple audio tracks as inputs in the Ducker

If you prefer working within the Inspector:

1	 Select the Freeway Traffic track, ensure the Ducker is switched on, and open the Inspector’s 
Audio tab.

2	 Click the plus sign to the right of the Source 1 drop‑down containing Dialogue 1 to create a 
drop-down menu for Source 2, then choose Dialogue 2 from the list.

3	 Click the plus sign to the right of the Source 2 drop-down to create a drop-down menu for 
Source 3, then choose Dialogue 3 from the list.
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Adding multiple audio tracks as ucker inputs via the Inspector

Track Management

Rearrange Tracks in the Mixer
You can reposition your tracks and busses in the Mixer by clicking and holding the track name 
and dragging left or right to the desired location. This works for both individual and selection of 
multiple channel strips. 

As you move your mouse, a white line will appear indicating the new location and the change will 
be reflected in the Index.Duplicating Timeline Tracks

Rearranging tracks by moving a Mixer Channel Strip
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Duplicating Timeline Tracks
Now, you can duplicate a track on the Fairlight Timeline by right-clicking a track header and 
choosing “Duplicate Track” from the contextual menu.

You can duplicate multiple tracks simultaneously by selecting them, right-clicking any track 
header in the group, and choosing “Duplicate Tracks” from the contextual menu. 

The names of duplicate tracks will be appended with the word “copy.” 

Timeline contextual menu - Deplete Tracks Duplicate Tracks with appended names

Groups Panel Access
A Groups button has been added to the interface toolbar, which lets you access the Groups list. 
The Groups list is now a separate panel that remains open when you close the Track Index or 
click one of  the other Index tabs.

Groups button on the Interface toolbar

Disable Audio Tracks via Mixer or Timeline
Disabling Tracks in the Timeline
You can disable an audio track by right-clicking its track header and choosing Disable Track from 
the contextual menu.

To disable multiple tracks simultaneously, select them, right-click any track header in the group, 
and choose Disable Tracks from the contextual menu.  
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To reenable your tracks, repeat one of the selection processes based on the number of 
tracks and choose Disable Track or Disable Tracks from the contextual menu.

Timeline contextual menu - Disable Tracks Disabled tracks

Disabling Tracks via the Mixer

You can disable an audio track in the Mixer by 
right-clicking the track number at the top of 
the corresponding channel strip and choosing 
Disable Track from the contextual menu. 
Repeating these  steps will re-enable the track.

To simultaneously disable multiple tracks, select 
them, Option right-click any track number in 
the group, and choose Disable Tracks from the 
contextual menu.

Disabling multiple tracks via the Mixer
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Delete Multiple Tracks via the Index
The Fairlight Track Index now supports deleting multiple tracks by right-clicking on a 
section of tracks and choosing Delete Tracks from the contextual menu.

Automation Improvements

Right-Click to View Track Automation
Overview
Fairlight lets you view track automation by right-clicking parameters on Fairlight FX, supported 
Audio Unit or VST plugins, or Mixer channel controls.

This time-saving feature is useful when working with Fairlight FX and supported Audio 
Units and VST effect plugins. For example, when working with some parametric EQ plugins 
or compatible emulations of famous mixer channel strips, right-clicking a parameter or 
control in the plugin GUI selects the parameter name from the Automation View submenu 
and displays it in the track header.  The current automation curve appears on the Timeline.

Automation curve

This workflow is much faster than manually scrolling through an extensive list of parameters 
in a Fairlight Automation View submenu to make your selection and then create or 
record your automation.

Automation contextual menu
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Trim Automation from Unity in the Mixer
Trim mode now supports automation trimming from unity (Fader set to 0) in the Fairlight Mixer 
by following the steps below:

1	 On the Automation toolbar, set the Automation mode to Trim. 

The Automation toolbar

2	 Choose a Touch mode (Latch, Snap, or Snap Latch).

3	 Click the Automation Arm button on the Mixer channel or tracks you want to trim.

TIP: You can either Command-Option click the Automation Arm button to trim 
automation on all tracks or Option-click the button to trim automation for a collection 
of tracks or Mixer channels you’ve selected.

4	 The Faders on the armed Mixer channels will turn yellow and snap to zero, and the dB 
Indicator above each armed fader will read Δ0.0dB.

5	 Begin playback and move the Fader above or below Δ0.0dB. The automation curve will be 
trimmed, and the dB Indicator will display the amount of trim as a plus or minus (+/-) value.

If you’ve chosen Snap mode, the Fader will return to Δ0.0dB based on the Glide time set in 
Preference > User > Fairlight > Automation. 

Mixer Faders set to trim  
automation from unity
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Multichannel Audio Improvements

Audio Configuration Pane Trim Control
The Audio Configuration pane in the File tab of the Inspector now includes a level control for 
trimming the level of individual channels of multichannel Media Pool or Timeline clips. This 
feature can be helpful when one or more channels aren’t loud enough and needs to be trimmed 
to match the other channels.

The level control becomes active once one or more channels are selected. When two or more 
channels are selected, they are simultaneously trimmed by the same amount (in dB).

NOTE: Higher trim level adjustments can cause clipping within the source clip.  

Audio Configuration pane - Media Pool clip Audio Configuration pane - Timeline clip

The appearance of the Audio Configuration pane will vary depending on the type of clip 
you’re trimming. When working with a clip in the Media Pool, the configuration pane displays a 
composite waveform of all channels within the file immediately below the Format drop-down.

When working with a timeline clip, the Audio Configuration pane displays the corresponding 
audio track number to the left of the individual channel waveforms.

Trim adjustments made within timeline clips are independent of their clip gain and do not affect 
their corresponding Media Pool clip.
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Changing Multichannel Audio Sources
Fairlight now supports changing mono audio sources within a multichannel timeline clip via 
the Inspector or a contextual menu on the Timeline. This is useful when audio issues, such as 
clipping or other unwanted noise, are found while editing or mixing.

When working within the 
Inspector, go to the Audio 
Configuration pane in the 
File tab, click the drop-down list 
under the channel source you 
want to change, and choose a 
suitable alternative.

Audio Channel Source menu - Inspector

To change an audio source 
on the Timeline, right-click 
the audio channel you need 
to correct and select an option 
from the list at the bottom of 
the contextual menu.

Audio Channel Source menu - Timeline menu

If you prefer a simplified 
menu containing only the 
available audio sources, 
Command right-click the 
audio channel in question.

Audio Channel Source menu - Simplified Timeline menu
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Other New Features in Fairlight

Additional Audio Format Support
DaVinci Resolve now supports Dolby Stereo Direct, 7.1.2, and 9.1.4 audio formats.

Fine Control Adjustments - Fairlight FX and Inspector
Fairlight supports “granular” control adjustments by holding down the Option or Shift key while 
clicking in and dragging left or right within the numerical value fields for virtual sliders in a 
Fairlight FX plugin or the Inspector.

Miscellaneous New Features
Improved visibility of clips being trimmed into by showing waveform overlay.

Improved clip name display, track resize behavior, and playhead indicator in the timeline.
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Deliver
DaVinci Resolve 19.1 has added new features to the Deliver page, as well as additional 
codec support.

Drag to Reorder Render Jobs 
in the Render Queue
You can now manually reorder the Render Queue by dragging a job up and down in the stack. 
The job numbers will remain in numerical order, but the actual render settings assigned to them 
will be replaced.

Dragging Job 3 (H.264) in front of 
Job 2 (ProRes) in the Render Queue.

Video Render Settings for Timeline 
Resolution and Frame Rate
In previous versions of DaVinci Resolve, the video frame rate and resolution in the Deliver Page 
render settings would automatically update to match the current resolution and frame rate of the 
timelines. However, this resolution and frame rate would get locked in when creating render presets.

In DaVinci Resolve 19.1, there are new options for Timeline Resolution and Timeline Frame Rate, 
which are selected by default. When presets and render jobs are created with these settings, 
render jobs and presets are dynamic and automatically changed to the currently loaded 
timeline/project. 

You still have the ability to create presets and render jobs at explicit resolutions and frame rates 
by selecting them directly during job creation. 
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Render Without Timecode 
for YouTube Preset
If you’re using certain editing tools on mobile devices that have issues with timecode, 
the YouTube preset now has a checkbox that lets you Render Without Timecode.

New Encode and Decode Support
DaVinci Resolve has added new or additional support for the following codecs:

Support for Encoding MV HEVC Spatial Video.

Ability to encode Sony MXF Op1A clips to an XDCAM drive from Mac and Windows.

Ability to encode H.265 Main10 formats in DaVinci Resolve on Windows.

Decode and encode EXR standard metadata attributes. 

Improved Panasonic P2 renders allowing compatibility with P2 Viewer.
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